Support phone number unavailable; you can reach us at 978-424-5364 instead or via support@fareharbor.com
Incident Report for FareHarbor
Resolved
This incident has been resolved.
Posted about 1 year ago. Oct 21, 2016 - 07:34 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 year ago. Oct 21, 2016 - 06:49 PDT
Investigating
The provider for our Support phone number currently has an outage. We have temporarily switched our number to 978-424-5364 until they are back up and running.
Posted about 1 year ago. Oct 21, 2016 - 06:12 PDT