FareHarbor Unavailable for Some Users
Incident Report for FareHarbor
Resolved
We're back!
Posted 2 months ago. Jul 06, 2018 - 15:21 PDT
Investigating
We're aware of an issue with fareharbor.com not loading or loading slowly for some users and our engineering team is actively investigating.
Posted 2 months ago. Jul 06, 2018 - 15:13 PDT
This incident affected: fareharbor.com.