FareHarbor Homepage and Help Pages Not Loading
Incident Report for FareHarbor
Resolved
This issue has been resolved. Happy FareHarboring!
Posted 5 months ago. Feb 14, 2018 - 17:30 PST
Investigating
We're aware of an issue causing the fareharbor.com homepage to not load for people who are logged out. If you're trying to log in, please visit https://fareharbor.com/login/.

The Dashboard, online booking, and payment processing are unaffected.

This issue with an upstream hosting provider also affects our help pages and some websites hosted by FareHarbor. We will have an update on this shortly.
Posted 5 months ago. Feb 14, 2018 - 16:15 PST