Support phone number unavailable; reach us at 888-255-8516 instead or via support@fareharbor.com
Incident Report for FareHarbor
Resolved
This issue has been resolved. Sorry for the trouble!
Posted 11 months ago. Feb 28, 2017 - 15:32 PST
Monitoring
The provider for our support phone lines is experiencing an outage. Please use the alternate number above if you need to contact us. Thank you!
Posted 11 months ago. Feb 28, 2017 - 10:48 PST