fareharbor.com not responding
Incident Report for FareHarbor
Resolved
We are recovered from this issue and seeing normal performance. We're sorry for the disruption.
Posted 16 days ago. Oct 04, 2018 - 12:18 PDT
Monitoring
Our automated systems have recovered from a hardware failure and things are returning to normal. We're continuing to closely monitor.
Posted 16 days ago. Oct 04, 2018 - 12:10 PDT
Investigating
The FareHarbor website is not responding for most users. We are actively investigating and will have more info soon.
Posted 16 days ago. Oct 04, 2018 - 11:55 PDT
This incident affected: fareharbor.com and Payment processing.