Issues with websites hosted by FareHarbor
Incident Report for FareHarbor
Resolved
FareHarbor Websites, Help Center, and the marketing website performance is back to normal. Our apologies for the disruption.
Posted 5 months ago. Jun 01, 2018 - 08:01 PDT
Investigating
We're investigating an issue causing FareHarbor Websites, the FareHarbor Help Center, and the FareHarbor homepage to not load. The FareHarbor Dashboard is unaffected. If you're trying to log in to your FareHarbor dashboard, please visit https://fareharbor.com/login/.
Posted 5 months ago. Jun 01, 2018 - 07:26 PDT
This incident affected: FareHarbor Sites, Help and marketing website pages, and FareHarbor Homepage.