Support phone number unavailable; you can reach us at 888-255-8516 instead or via support@fareharbor.com
Incident Report for FareHarbor
Resolved
Our phones are fully operational, let us know how we can help!
Posted 9 months ago. Jan 04, 2017 - 13:12 PST
Monitoring
The provider for our primary Support phone number currently has an outage. We are available at 888-255-8516 until they are back up and running.
Posted 9 months ago. Jan 04, 2017 - 12:11 PST