Support phone lines partial outage
Incident Report for FareHarbor
Resolved
Our Support phones are back up and running. Reach us at 855-495-5551 or support@fareharbor.com
Posted 10 days ago. May 10, 2018 - 08:30 PDT
Investigating
Our Support phones are experiencing a partial outage. You can reach us on our temporary emergency line at 888-255-8516 or support@fareharbor.com in the meantime.
Posted 10 days ago. May 10, 2018 - 07:48 PDT
This incident affected: Support phone lines.