Degraded Dashboard Performance
Incident Report for FareHarbor
Resolved
Site performance is back to normal. Our apologies for the disruption!
Posted 3 months ago. Aug 17, 2017 - 16:51 PDT
Monitoring
We are seeing things return to normal. We are still closely monitoring.
Posted 3 months ago. Aug 17, 2017 - 16:45 PDT
Investigating
Some Dashboard users are currently experiencing slow load times. We are investigating.
Posted 3 months ago. Aug 17, 2017 - 16:26 PDT