FareHarbor Unavailable for Some Users
Incident Report for FareHarbor
Resolved
This issue has been resolved. Sorry for the hiccup!
Posted 5 months ago. May 03, 2018 - 11:56 PDT
Monitoring
We are seeing the site running normally. We'll keep a close eye on things for the next few minutes to make sure everything is good to go.
Posted 5 months ago. May 03, 2018 - 11:51 PDT
Investigating
We are actively investigating reports of fareharbor.com being unavailable for some users. We'll post an update here soon.
Posted 5 months ago. May 03, 2018 - 11:43 PDT
This incident affected: fareharbor.com, Help and marketing website pages, and FareHarbor Homepage.