Possible Issues Processing Payments
Incident Report for FareHarbor
Resolved
This issue has been resolved. Our apologizes for any disruption!
Posted over 1 year ago. Mar 25, 2016 - 17:08 PDT
Identified
Our payment processor has identified an elevated error rate for some customers. We are investigating.
Posted over 1 year ago. Mar 25, 2016 - 16:58 PDT
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Mar 25, 2016 - 16:57 PDT