Support Phone Number Unavailable
Incident Report for FareHarbor
Resolved
The issue has been fully resolved and our phones are operational again!
Posted about 1 year ago. Aug 26, 2016 - 11:23 PDT
Monitoring
The provider for our Support phone number is experiencing an issue that is causing calls to not go through. We are monitoring and they expect to have things resolved shortly.

We are still available at support@fareharbor.com or by phone at 774-217-0198.

The Dashboard and the rest of FareHarbor are not affected. Our apologies for any inconvenience.
Posted about 1 year ago. Aug 26, 2016 - 09:27 PDT