Partial Website Outage
Incident Report for FareHarbor
Resolved
This issue has been resolved. Our apologies for any inconvenience.
Posted about 2 years ago. Mar 10, 2016 - 13:15 PST
Identified
Some users are having issues loading fareharbor.com. We are investigating.
Posted about 2 years ago. Mar 10, 2016 - 13:06 PST