FareHarbor Homepage and Help Pages Not Loading
Incident Report for FareHarbor
This issue has been resolved. Sorry for the trouble!
Posted 4 months ago. Dec 01, 2017 - 15:25 PST
We are continuing work with our upstream provider on this issue. We've updated the fareharbor.com homepage to make sure you're able to log in to your Dashboard.
Posted 4 months ago. Dec 01, 2017 - 15:12 PST
We're aware of an issue causing the fareharbor.com homepage to not load for people who are logged out. If you're trying to log in, please visit https://fareharbor.com/login/.

The Dashboard, online booking, and payment processing are unaffected.

This issue with our upstream hosting provider also affects our help pages and some websites hosted by FareHarbor. We will have an update on this shortly.
Posted 4 months ago. Dec 01, 2017 - 14:13 PST