Elevated credit card error rates
Incident Report for FareHarbor
Resolved
This problem has been resolved. Sorry for the hiccup!
Posted almost 2 years ago. Nov 06, 2015 - 14:34 PST
Identified
Our processor for credit card payments is experiencing an issue that is causing a percentage of credit card charges to fail. We are investigating, and the rest of the Dashboard is still working normally.
Posted almost 2 years ago. Nov 06, 2015 - 14:29 PST