Elevated credit card error rates
Incident Report for FareHarbor
Resolved
This issue has been resolved. Very sorry for the trouble!
Posted 6 months ago. May 16, 2017 - 11:34 PDT
Monitoring
We are in contact with our processor and they are aware of the issue and working on a fix.
Posted 6 months ago. May 16, 2017 - 11:26 PDT
Identified
Our processor for credit card payments is experiencing an issue that is causing a percentage of credit card charges to fail. We are investigating, and the rest of the Dashboard is still working normally.
Posted 6 months ago. May 16, 2017 - 10:45 PDT