Support Phone Lines Experiencing Partial Outage
Incident Report for FareHarbor
Resolved
Our support phones are back up and running. Reach us at: US/Canada: 855-495-5551, Australia: +61 1800-951-984, UK: 0-800-069-8606, or send us an email at support@fareharbor.com!
Posted 4 months ago. Aug 08, 2018 - 10:49 PDT
Monitoring
Our Support phones are back up and running. Reach us at 855-495-5551 or support@fareharbor.com
Posted 4 months ago. Aug 08, 2018 - 10:12 PDT
Update
We are continuing to investigate this issue.
Posted 4 months ago. Aug 08, 2018 - 09:25 PDT
Investigating
Our Support phones are experiencing a partial outage. You can reach us on our temporary emergency line at 888-255-8516 or support@fareharbor.com in the meantime.
Posted 4 months ago. Aug 08, 2018 - 09:06 PDT
This incident affected: Support phone lines.