Increased Visa and MasterCard declines
Incident Report for FareHarbor
Resolved
This issue has been resolved. Our apologies for the trouble.
Posted 6 months ago. Apr 08, 2017 - 22:43 PDT
Investigating
Our upstream payment provider is experiencing increased declines for Visa and MasterCard cards in some cases. The rest of FareHarbor is operational and they are working on a solution.
Posted 6 months ago. Apr 08, 2017 - 22:09 PDT