Degraded Dashboard Performance
Incident Report for FareHarbor
Resolved
Dashboard performance is back to normal. Our apologies for the disruption!
Posted 7 months ago. Apr 24, 2018 - 15:51 PDT
Update
We’re continuing to work to improve load times. Please contact support@fareharbor.com if you are experiencing issues using your Dashboard.
Posted 7 months ago. Apr 24, 2018 - 12:57 PDT
Investigating
FareHarbor is experiencing longer than normal load times in some instances. We are working on a fix. More information to follow.
Posted 7 months ago. Apr 24, 2018 - 10:36 PDT