Fareharbor is experiencing slowness issues.

Incident Report for FareHarbor

Resolved

The issue appears to have resolved itself.
Posted Sep 24, 2025 - 06:48 PDT

Investigating

Our team is continuing to investigate slowness issue. We will provide an update with more information.
Posted Sep 24, 2025 - 05:08 PDT
This incident affected: Dashboard (Dashboard, Online booking).