Fareharbor is experiencing slowness issues.

Incident Report for FareHarbor

Resolved

This incident has been resolved.
Posted May 22, 2026 - 10:37 PDT

Monitoring

We are seeing load times return to normal. We are monitoring the issue.
Posted May 22, 2026 - 10:30 PDT

Investigating

We are currently investigating this issue.
Posted May 22, 2026 - 10:20 PDT
This incident affected: Dashboard (Dashboard Booking & Actions).