Dashboard unavailable
Incident Report for FareHarbor
Resolved
This incident has been resolved.
Posted Jun 03, 2024 - 12:37 PDT
Update
We are continuing to investigate the issue.
Posted Jun 03, 2024 - 12:25 PDT
Investigating
We are currently investigating the issue.
Posted Jun 03, 2024 - 11:59 PDT
This incident affected: Dashboard (Dashboard and online booking, Reporting, Search, Payment processing, Email delivery, SMS message delivery).