Monitoring potential impact due to Cloudflare outage

Incident Report for FareHarbor

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 12:56 PST

Update

We’re seeing services return to normal levels. Performance on FareHarbor Sites is stabilizing as Cloudflare recovers.

We’ll continue to monitor for any lingering impact and update Statuspage once everything is fully confirmed as resolved.
Posted Nov 18, 2025 - 06:59 PST

Update

We’ve identified that some FareHarbor Sites are currently experiencing degraded performance, likely related to the ongoing Cloudflare outage.

Our team is actively monitoring the situation and working with our providers to ensure stability. We’ll continue to share updates as more information becomes available.
Posted Nov 18, 2025 - 06:53 PST

Monitoring

We’re aware of an ongoing issue with Cloudflare that may affect some online services globally. At this time, FareHarbor systems are operating normally, and we have not received any reports of downtime or disruption.

Our team is closely monitoring the situation and will provide updates if we detect any impact on FareHarbor services.
Posted Nov 18, 2025 - 06:29 PST
This incident affected: FareHarbor Sites.