Image Upload Issue

Incident Report for FareHarbor

Resolved

This incident has been resolved and we're seeing normal performance across the site. Our apologies for the disruption!
Posted Feb 17, 2026 - 05:40 PST

Investigating

We are currently experiencing an issue affecting photo uploads. The problem originates from the third-party service, and we are closely monitoring the situation. We will share updates as soon as they become available.
Posted Feb 17, 2026 - 04:29 PST
This incident affected: Dashboard (Dashboard).