Emails Sent to Yahoo and AOL Addresses Are Being Blocked or Rejected
Incident Report for FareHarbor
Resolved
We have started seeing the services normalising, for the past 30 minutes all emails to Yahoo/AOL have been successfully received.
We will keep everyone updated with any new findings in our investigation. We are marking this issue as closed, while we continue to investigate the cause of it.
Posted Nov 29, 2024 - 15:14 PST
Identified
The issue has been identified, and we are working trying to implement a solution.
Posted Nov 29, 2024 - 10:39 PST
Investigating
We are currently experiencing an issue where emails sent to @yahoo.com and @aol.com addresses are being rejected or blocked. Our team is actively investigating the root cause and working on a solution to resolve this as quickly as possible.
Posted Nov 29, 2024 - 10:05 PST
This incident affected: Dashboard (Email delivery).