Fareharbor is experiencing issues with Online Booking.

Incident Report for FareHarbor

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 09:00 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2025 - 08:33 PDT

Identified

We are aware that some users may be experiencing issues with Online Booking. Our team is currently investigating and working to resolve the issue as quickly as possible. We will provide updates here as more information becomes available. We apologize for any inconvenience and appreciate your patience.
Posted Aug 18, 2025 - 08:21 PDT
This incident affected: Dashboard (Online booking).