Email not sending for some users

Incident Report for FareHarbor

Resolved

This incident has been resolved. Email functionality is fully restored and all affected emails have been sent.
Posted Oct 22, 2020 - 05:45 PDT

Monitoring

We've isolated the issue to an upstream email provider and have resolved these issues. Email should now be sending properly. We will continue to monitor.
Posted Oct 22, 2020 - 05:27 PDT

Investigating

Some emails are currently not being delivered. We are investigating the issue and will update as we have more information.
Posted Oct 22, 2020 - 03:55 PDT