Photo Upload Issues

Incident Report for FareHarbor

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 04:26 PDT

Investigating

We are investigating an issue affecting photo uploads in the FareHarbor Dashboard. Users may experience errors when attempting to upload images. The issue appears to be related to a disruption with Filestack, our third-party file upload provider. We are working with the vendor and will provide updates as more information becomes available.
Posted Jun 01, 2026 - 02:02 PDT
This incident affected: Dashboard (Dashboard Booking & Actions).