Service Degradation Due to External Cloud Provider Issues

Incident Report for FareHarbor

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 05:26 PDT

Identified

We are experiencing a partial outage due to some issue at the end of our public cloud provider. ETA of the same is not know at the moment.
Posted Oct 20, 2025 - 03:16 PDT
This incident affected: Dashboard (Online booking).