Some FareHarbor Sites not loading
Incident Report for FareHarbor
Resolved
This incident has been resolved and all FareHarbor Sites are functioning normally.
Posted Feb 02, 2021 - 01:28 PST
Investigating
We are currently investigating FareHarbor Sites availability, including the loading of help page and some websites.

The FareHarbor dashboard is functional normally.
Posted Feb 02, 2021 - 01:11 PST
This incident affected: FareHarbor Sites and Client support (Help pages).