FareHarbor.com Credit Card Payments
Incident Report for FareHarbor
Resolved
This issue was resolved at 17:03 UTC.
Posted 2 months ago. Jul 10, 2019 - 14:23 PDT
Update
Payment processing has returned to normal, and we will continue to monitor. We're sorry for the inconvenience. Please reach out to support if you need anything.
Posted 2 months ago. Jul 10, 2019 - 10:11 PDT
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Jul 10, 2019 - 10:10 PDT
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Jul 10, 2019 - 10:08 PDT
Identified
We're aware of an issue with some credit card payments failing. This is an issue with our payment provider. We will continue to monitor the situation and post updates.
Posted 2 months ago. Jul 10, 2019 - 10:03 PDT
This incident affected: Dashboard (Payment processing).