Dashboard and online booking pages loading slowly
Incident Report for FareHarbor
Resolved
We've identified and fixed the cause of this issue and are seeing things loading normally again. We will continue to monitor, and we're sorry for the disruption to your day!
Posted Mar 31, 2021 - 12:38 PDT
Investigating
We are investigating an issue causing the Dashboard and online booking pages to run slowly, and will have an update soon.
Posted Mar 31, 2021 - 12:14 PDT
This incident affected: Dashboard (Dashboard and online booking).