Support phone numbers unavailable
Incident Report for FareHarbor
Resolved
This incident has been resolved. The provider for our support phone lines has returned to normal performance. Sorry for the interruption!
Posted about 1 month ago. Sep 16, 2019 - 13:17 PDT
Monitoring
We're beginning to see improvement and are continuing to monitor the incident.
Posted about 1 month ago. Sep 16, 2019 - 12:28 PDT
Identified
The provider for our support phone lines is experiencing a partial outage. The FareHarbor Dashboard is unaffected. You can reach us at support@fareharbor.com in the meantime.
Posted about 1 month ago. Sep 16, 2019 - 11:30 PDT
This incident affected: Client support (Support phone lines).