Dashboard Performance Issues

Incident Report for FareHarbor

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 02:34 PDT

Investigating

We are currently investigating slowness affecting users.
Posted Jul 02, 2026 - 01:46 PDT
This incident affected: Dashboard (Dashboard Booking & Actions).