Due to an outage affecting our upstream provider, AWS, some FareHarbor services are currently impacted.

Incident Report for FareHarbor

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 05:16 PDT

Monitoring

Our engineering team is monitoring the situation. We will provide another update as soon as more information becomes available.
Posted Jul 16, 2026 - 02:39 PDT
This incident affected: FareHarbor Ecosystem (Marketplace, Desk).