Support phone number is unavailable; please contact us at support@fareharbor.com or 888-255-8516.
Incident Report for FareHarbor
Resolved
The issue has been resolved and our phones are operational again!
Posted 8 months ago. Mar 28, 2017 - 11:33 PDT
Investigating
The provider for our support phone lines is experiencing a partial outage. Please use the alternate number above or email support@fareharbor.com if you need to contact us. Thank you!
Posted 8 months ago. Mar 28, 2017 - 10:45 PDT