Support phone number unavailable; you can reach us at 978-424-5364 instead or via support@fareharbor.com
Incident Report for FareHarbor
Resolved
This incident has been resolved.
Posted 11 months ago. Oct 21, 2016 - 14:22 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 11 months ago. Oct 21, 2016 - 11:49 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 11 months ago. Oct 21, 2016 - 10:06 PDT
Investigating
We are currently investigating this issue.
Posted 11 months ago. Oct 21, 2016 - 09:31 PDT