Support phone number unavailable; reach us at 559-424-3643 instead
Incident Report for FareHarbor
Resolved
The issue has been fully resolved and our phones are operational again!
Posted about 1 year ago. Sep 22, 2016 - 17:48 PDT
Monitoring
It seems this issue is mostly resolved. We are still monitoring.
Posted about 1 year ago. Sep 22, 2016 - 17:16 PDT
Identified
The provider for our Support phone number is experiencing an issue that is causing calls to not go through. We are monitoring and they expect to have things resolved shortly.

We are still available at support@fareharbor.com or by phone at 559-424-3643.

The Dashboard and the rest of FareHarbor are not affected. Our apologies for the hiccup.
Posted about 1 year ago. Sep 22, 2016 - 16:33 PDT