Website Unavailable
Incident Report for FareHarbor
Resolved
We've fixed the problem causing this, and we'll post an update here in the next couple days about how we will avoid it happening again. We sincerely apologize for the trouble. Have a good day!
Posted 2 months ago. May 18, 2018 - 06:12 PDT
Identified
We're still working on this issue, and there's a code change in progress that should help clear things up. We know your day is likely getting started and are doing everything we can to get things going again.
Posted 2 months ago. May 18, 2018 - 06:04 PDT
Investigating
We're investigating an issue that is causing fareharbor.com to be unavailable. We'll have an update soon.
Posted 2 months ago. May 18, 2018 - 05:45 PDT
This incident affected: fareharbor.com.