Support phone number unavailable; reach us at 888-255-8516 instead or via support@fareharbor.com
Incident Report for FareHarbor
Resolved
The issue has been resolved and our phones are operational again!
Posted 6 months ago. Mar 15, 2017 - 16:19 PDT
Monitoring
It seems this issue is mostly resolved. We are still monitoring.
Posted 6 months ago. Mar 15, 2017 - 16:08 PDT
Investigating
The provider for our support phone lines is experiencing a partial outage. Please use the alternate number above or email support@fareharbor.com if you need to contact us. Thank you!
Posted 6 months ago. Mar 15, 2017 - 12:39 PDT