Support phone number unavailable; you can reach us at 774-217-0198 instead or via support@fareharbor.com
Incident Report for FareHarbor
Resolved
This incident has been resolved.
Posted 11 months ago. Oct 21, 2016 - 18:38 PDT
Investigating
We are currently investigating this issue.
Posted 11 months ago. Oct 21, 2016 - 15:48 PDT