Support phone number unavailable; reach us at 559-424-3643 instead
Incident Report for FareHarbor
Resolved
Our phones are fully operational, let us know how we can help!
Posted 11 months ago. Oct 13, 2016 - 12:42 PDT
Update
We are seeing improvements, calls are completing as expected. We will continue to monitor.
Posted 11 months ago. Oct 13, 2016 - 12:26 PDT
Monitoring
The provider for our Support phone number currently has an outage. We have temporarily switched our number to 559-424-3643 until they are back up and running.
Posted 11 months ago. Oct 13, 2016 - 11:02 PDT